Class AcadBlock
Member of BricscadDb
The Block object represents one or more entities grouped together to create a single entity. The Block definition contains a name and a set of entities. To insert a block into a drawing, use the InsertBlock method. To edit or query a block definition, use the following methods and properties:
Methods | Properties |
---|---|
Add3DFace | Application |
Add3DMesh | BlockScaling |
Add3DPoly | Comments |
AddArc | Count |
AddAttribute | Document |
AddBox | Explodable |
AddCircle | Handle |
AddCone | HasExtensionDictionary |
AddCylinder | IsDynamicBlock |
AddDim3PointAngular | IsLayout |
AddDimAligned | IsXRef |
AddDimAngular | Layout |
AddDimDiametric | Name |
AddDimOrdinate | ObjectID |
AddDimRadial | ObjectName |
AddDimRotated | Origin |
AddEllipse | OwnerID |
AddHatch | Path |
AddImage | Units |
AddLeader | XRefDatabase |
AddLightWeightPolyline | |
AddLine | |
AddMText | |
AddPoint | |
AddPolyfaceMesh | |
AddPolyline | |
AddRay | |
AddRegion | |
AddRevolvedSolid | |
AddSection | |
AddShape | |
AddSolid | |
AddSphere | |
AddSpline | |
AddTable | |
AddText | |
AddTolerance | |
AddTorus | |
AddTrace | |
AddWedge | |
AddXLine | |
AttachExternalReference | |
Bind | |
Delete | |
Detach | |
GetExtensionDictionary | |
GetXData | |
InsertBlock | |
Item | |
Reload | |
SetXData | |
Unload | |
WBlock |
© Bricsys NV. All rights reserved. |