key, string identifier of a DCL tile
as it appears in the DCL file
argument 2:
data to be attached to the tile. If
this function is accessed through lisp, this argument is a string.
If this function is accessed using an API other than lisp, this
argument is a pointer to data of any type.
return value:
T on success, nil on failure
description:
Associates client data with the
specified tile. The meaning of this data is the responsibiltiy of
the calling program. The client data can be retrieved by a callback
function that is set up by action_tile.