optional argument specifying the
integer return code of the dialog, default value 0
return value:
T on success, nil on failure
description:
This function closes and destroys a
dialog that was created with new_dialog. If start_dialog was called
on the dialog, the modal flow will return. The default behaviour
for an ok button is to call done_dialog with argument 1. The
default behaviour for a close or cancel button is to call
done_dialog with argument 0. When all dcl dialogs are closed using
term_dialog, done_dialog will be called with argument -1.