dumpAllProperties
(dumpallproperties ename
[context])
This function lists all available properties
for the specified ename
entity.
Arguments
|
ename (classic entity name) object or entity ename to dump
all properties for
context (integer 0/1) defines whether aggregated
properties are shown "expanded" or "collapsed" (ignored in
BricsCAD)
|
Return
|
NIL always
|
Example
|
(dumpallproperties
(entlast))
===== begin object dump for
<AcDbLine>
----- Database Properties
Angle (ident: "Angle~Native") (double)
(RO) = 0.447612328315
Annotative (ident: "Annotative~Native")
(bool) (RO) = 0
BlockId (ident: "BlockId~Native")
(AcDbObjectId) (RO) = 0x3cfec3f0
:
----- BIM Properties
AssemblyCode (ident: "AssemblyCode~BIM")
(string) = <no value>
AssemblySubtype (ident: "AssemblySubtype~BIM")
(string) = <no value>
AxisAngle (ident: "AxisAngle~BIM")
(double) = <no value>
:
----- Quantities Properties
CrossSectionArea (ident:
"CrossSectionArea~Quantity") (double) (RO) = <no
value>
GrossArea (ident: "GrossArea~Quantity")
(double) (RO) = <no value>
GrossFootprintArea (ident:
"GrossFootprintArea~Quantity") (double) (RO) = <no
value>
:
|
Hint
|
the specified "ident" can be
used to uniquely specify the property, as same-named properties can
exist in multiple NameSpaces;
the ident always uses the format
"Name~NameSpace"
|
Remarks
|
1. boolean values (in
AutoLISP T/NIL) are always and generally reported as integer
0/1
2. the "context" flag is ignored in BricsCAD :
accessing "Point/X" for read or write does not properly work on
AutoLISP, no sense to support this
3. BricsCAD LISP additionally lists properties
from BIM Quantity MCAD Civil IFC2x3
IFC4 PointCloud Bsyslib and application NameSpaces as
well
|