ImageBGRA32 Class

This class defines image color parameters in RGBA format, which stores an integer for red, green, and blue values, and includes a value for alpha-shading.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GraphicsInterfaceImageBGRA32

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public class ImageBGRA32 : DisposableWrapper

The ImageBGRA32 type exposes the following members.

Constructors
  Name Description
Public method ImageBGRA32 Default constructor for the ImageBGRA32 class. Creates an object with no underlying image and with 0 width and height.
Protected method ImageBGRA32(IntPtr, Boolean) Initializes a new instance of the ImageBGRA32 class
Public method ImageBGRA32(UInt32, UInt32, IntPtr) Constructor for the ImageBGRA32 class. Creates an image with the specified width, height and pixel data.
Top
Properties
  Name Description
Public property Height Property that represents the height of this image.
Public property Image Property that represents the pixel data of this image.
Public property Width Property that represents the width of this image.
Top
Methods
  Name Description
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Top
See Also

©  Bricsys NV. All rights reserved.