AcSmSheetSetClass Class

Inheritance Hierarchy
SystemObject
  BricscadSmAcSmSheetSetClass

Namespace: BricscadSm
Assembly: BricscadSm (in BricscadSm.dll) Version: 25.0.0.0
Syntax
public class AcSmSheetSetClass : IAcSmSheetSet, 
        AcSmSheetSet, IOdSmInternal

The AcSmSheetSetClass type exposes the following members.

Constructors
  Name Description
Public method AcSmSheetSetClass Initializes a new instance of the AcSmSheetSetClass class
Top
Methods
  Name Description
Public method AddNewSheet  
Public method Clear  
Public method CreateSubset  
Public method GetAltPageSetups  
Public method GetCalloutBlocks  
Public method GetClassID  
Public method GetCustomPropertyBag  
Public method GetDatabase  
Public method GetDefAltPageSetup  
Public method GetDefDwtLayout  
Public method GetDefLabelBlk  
Public method GetDesc  
Public method GetDirectlyOwnedObjects  
Public method GetDirectlyOwnedObjectsArray  
Public method GetImpl  
Public method GetIsDirty  
Public method GetName  
Public method GetNewSheetLocation  
Public method GetObjectId  
Public method GetOwner  
Public method GetPromptForDwgName  
Public method GetPromptForDwt  
Public method GetPublishOptions  
Public method GetResources  
Public method GetSheetEnumerator  
Public method GetSheetSelSets  
Public method GetTypeName  
Public method GetViewCategories  
Public method ImportSheet  
Public method InitNew  
Public method InsertComponent  
Public method InsertComponentAfter  
Public method Load  
Public method NotifyRegisteredEventHandlers  
Public method Register  
Public method RemoveSheet  
Public method RemoveSubset  
Public method Save  
Public method SetAltPageSetups  
Public method SetDefAltPageSetup  
Public method SetDefDwtLayout  
Public method SetDefLabelBlk  
Public method SetDesc  
Public method SetImpl  
Public method SetName  
Public method SetNewSheetLocation  
Public method SetOwner  
Public method SetPromptForDwgName  
Public method SetPromptForDwt  
Public method Sync  
Public method Unregister  
Public method UpdateInMemoryDwgHints  
Public method UpdateSheetCustomProps  
Top
See Also

©  Bricsys NV. All rights reserved.