AssocEvaluationCallback Class

This .NET class wraps the OdDbAssocEvaluationCallback class.

This class implements a mechanism for associative actions (represented by the AssocActions class) to notify about the progress of evaluation, to report about the result of evaluation, notify about which objects will be used and modified by the action, to allow the evaluation programs to be terminated by the client, etc.

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.DatabaseServicesAssocEvaluationCallback

Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public abstract class AssocEvaluationCallback : DisposableWrapper

The AssocEvaluationCallback type exposes the following members.

Properties
  Name Description
Top
Methods
  Name Description
Public method BeginActionEvaluation Initiates action evaluation. This callback is called inside the AssocAction.Evaluate() method and should not be called from the individual EvaluateOverride() method calls. Currently not implemented.
Public method BeginActionEvaluationUsingObject Initiates action evaluation. The action informs that it will perform read and write operations on the object represented by objectId. The action uses this callback just before it opens the object for read or write. Currently not implemented.
Public method CancelActionEvaluation Initiates action evaluation. The action informs that it will perform read and write operations on the object represented by objectId. The action uses this callback just before it opens the object for read or write. Currently not implemented.
Public method DeleteUnmanagedObject Deletes a pointer to the wrapped corresponding C++ OdDbAssocTransformationType object.
(Overrides DisposableWrapperDeleteUnmanagedObject)
Public method EndActionEvaluation The action informs that it has finished its evaluation.
Public method EndActionEvaluationUsingObject The action informs that it has finished performing read and/or write operations on the specified object represented by obj.
Top
See Also

©  Bricsys NV. All rights reserved.