BrepEntity Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.BoundaryRepresentationBrepEntity
        More

Namespace: Teigha.BoundaryRepresentation
Assembly: TD_MgdBrep (in TD_MgdBrep.dll) Version: 0.0.0.0
Syntax
public abstract class BrepEntity : DisposableWrapper

The BrepEntity type exposes the following members.

Properties
  Name Description
Public property BoundBlock  
Public property Brep  
Public property IsNull  
Public property SubentityPath  
Public property ValidationLevel  
Top
Methods
  Name Description
Public method CheckEntity  
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Public method Equals
(Overrides DisposableWrapperEquals(Object))
Public method GetLineContainment  
Public method GetMassProperties  
Public method GetMassProperties(Double)  
Public method GetMassProperties(Double, Double)  
Public method GetMassProperties(Double, Double, Double)  
Public method GetPerimeterLength  
Public method GetPerimeterLength(Double)  
Public method GetPerimeterLength(Double, Double)  
Public method GetPointContainment  
Public method GetSurfaceArea  
Public method GetSurfaceArea(Double)  
Public method GetSurfaceArea(Double, Double)  
Public method GetVolume  
Public method GetVolume(Double)  
Public method GetVolume(Double, Double)  
Top
See Also
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.BoundaryRepresentationBrepEntity
        Teigha.BoundaryRepresentationBoundaryLoop
        Teigha.BoundaryRepresentationBrep
        Teigha.BoundaryRepresentationComplex
        Teigha.BoundaryRepresentationEdge
        Teigha.BoundaryRepresentationFace
        Teigha.BoundaryRepresentationShell
        Teigha.BoundaryRepresentationVertex

©  Bricsys NV. All rights reserved.