Vector3dProjectTo Method

Retrieves a 3D vector produced by the parallel projection of this vector onto the plane with a specified plane normal at the plane origin.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public Vector3d ProjectTo(
        Vector3d planeNormal,
        Vector3d projectDirection
)

Parameters

planeNormal  Vector3d
[in] Plane normal.
projectDirection  Vector3d
[in] Projection direction.

Return Value

Vector3d
Projected 3D vector.
See Also

©  Bricsys NV. All rights reserved.