Curve2dGetArea(Double, Double, Tolerance) Method

Retrieves the area of the parametric interval defined by the passed start and end parameters within the specified tolerance.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public double GetArea(
        double startParameter,
        double endParameter,
        Tolerance tolerance
)

Parameters

startParameter  Double
[in] Start of the parameter interval.
endParameter  Double
[in] End of the parameter interval (must be greater than startParameter).
tolerance  Tolerance
[in] Geometric tolerance.

Return Value

Double
Area calculated between specified parameters.
See Also

©  Bricsys NV. All rights reserved.