SweepOptions Class

This class contains options used for creating swept surfaces and swept solids (by calling SweptSurface.createSweptSurface() or Solid3d.createSweptSolid() methods). Sweep options are used to control the shape of the resulting surface or solid object.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.DatabaseServicesSweepOptions

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public class SweepOptions : DisposableWrapper, 
        ICloneable

The SweepOptions type exposes the following members.

Constructors
  Name Description
Public method SweepOptions Default constructor for the SweepOptions class.
Public method SweepOptions(SweepOptions) Copy constructor for the SweepOptions class.
Protected method SweepOptions(IntPtr, Boolean) Initializes a new instance of the SweepOptions class
Top
Properties
  Name Description
Public property Align Property that represents the alignment.
Public property AlignAngle Property that represents the align angle value in radians.
Public property AlignStart Property that represents the align to start option. If true, alignment to the start of the curve is applied. If false, alignment to the end of the curve is applied.
Public property Bank Property that indicates whether the swept face or curve is banked along the sweep path.
Public property BasePoint Property that represents the base point for alignment.
Public property CheckIntersections Property that indicates the state of the self-intersection check option. If this option is disabled, a self-intersected surface or solid can be created.
Public property DraftAngle Property that represents the draft angle by which the profile will taper as it is swept.
Public property EndDraftDist Property that represents the end draft distance.
Public property PathEntityTransform Property that represents the transformation matrix for a coordinate system at the start and end of the path curve.
Public property ScaleFactor Property that represents the scale factor.
Public property StartDraftDist Property that represents the start draft distance.
Public property SweepEntityTransform Property that represents the transformation matrix for the coordinate system of the swept entity.
Public property TwistAngle Property that represents the twist angle by which the profile is twisted as it is swept.
Top
Methods
  Name Description
Public method CheckPathCurve Checks whether the passed path curve is valid.
Public method CheckSweepCurve Checks whether the specified swept entity is valid and returns the planarity of the swept entity.
Public method Clone Clones this instance.
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Top
See Also

©  Bricsys NV. All rights reserved.