Point3dCollection Class

This class represents a collection of 3d points.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryPoint3dCollection

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public sealed class Point3dCollection : DisposableWrapper, 
        IList

The Point3dCollection type exposes the following members.

Constructors
  Name Description
Public method Point3dCollection Default constructor for the Point3dCollection class. Creates an empty collection of 3d points.
Public method Point3dCollection(Point3d) Constructor for the Point3dCollection class. Creates a collection of 3d points from the passed array.
Top
Properties
  Name Description
Public property Count Represents the number of elements that this collection currently stores.
Public property IsFixedSize Property that indicates whether this collection has a fixed size.
Public property IsReadOnly Property that indicates whether this collection is read-only.
Public property IsSynchronized Property that indicates whether access to this collection is thread-safe.
Public property Item Property that represents an item from the collection at the specified index.
Public property SyncRoot Property that represents an object that can be used to synchronize access to this collection.
Top
Methods
  Name Description
Public method Add Adds a point to the collection.
Public method Clear Clears this collection of 3d points.
Public method Contains Checks whether this collection contains a point that matches the specified point.
Public method CopyTo Copies this point collection to specified array at the specified index.
Public method GetEnumerator Returns enumerator for this point collection.
Public method IndexOf Returns index of the point in collection that matches the specified point.
Public method Insert Inserts the specified point to the collection at the provided index.
Public method Remove Removes a point in the collection that matches the specified point.
Public method RemoveAt Removes a point from the collection at the specified index.
Public method ToArray Returns this collection as an array of 3d points.
Top
See Also

©  Bricsys NV. All rights reserved.