AbstractViewPESetView(Point3d,
Vector3d, Vector3d, Double, Double, Boolean,
Vector2d) Method
|
Sets the parameters for the specified Viewport
object according to the arguments.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public void SetView(
Point3d target,
Vector3d direction,
Vector3d upVector,
double fieldWidth,
double fieldHeight,
bool isPerspective,
Vector2d viewOffset
)
Public Sub SetView (
target As Point3d,
direction As Vector3d,
upVector As Vector3d,
fieldWidth As Double,
fieldHeight As Double,
isPerspective As Boolean,
viewOffset As Vector2d
)
public:
void SetView(
Point3d target,
Vector3d direction,
Vector3d upVector,
double fieldWidth,
double fieldHeight,
bool isPerspective,
Vector2d viewOffset
)
member SetView :
target : Point3d *
direction : Vector3d *
upVector : Vector3d *
fieldWidth : float *
fieldHeight : float *
isPerspective : bool *
viewOffset : Vector2d -> unit
Parameters
- target Point3d
- [in] WCS view target.
- direction Vector3d
- [in] WCS view direction.
- upVector Vector3d
- [in] WCS up vector.
- fieldWidth Double
- [in] DCS field width.
- fieldHeight Double
- [in] DCS field height.
- isPerspective Boolean
- [in] Flag that specifies whether the projection is perspective.
If false, the projection is parallel.
- viewOffset Vector2d
- [in] View offset vector.
See Also