BIMComposition Class |
The BIMComposition type exposes the following members.
Name | Description | |
---|---|---|
![]() |
BIMComposition | Initializes a new instance of the BIMComposition class |
![]() |
BIMComposition(BIMComposition) | Initializes a new instance of the BIMComposition class |
![]() |
BIMComposition(String) | Initializes a new instance of the BIMComposition class |
Name | Description | |
---|---|---|
![]() |
![]() |
![]() |
![]() |
Comments | |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
Layer | |
![]() |
![]() |
Type | |
![]() |
![]() |
VariablePlyIndex |
Name | Description | |
---|---|---|
![]() ![]() |
AddMaterialsAndCompositionsFromXML | |
![]() ![]() |
AllObjectCompositions | |
![]() ![]() |
AllStringCompositions | |
![]() |
AssignToEntity(ObjectId, Double) | |
![]() ![]() |
AssignToEntity(String, ObjectId, Double) | |
![]() ![]() |
AvailableObjectCompositions | |
![]() ![]() |
AvailableStringCompositions | |
![]() ![]() |
Cast | |
![]() |
![]() |
DeleteComposition | |
![]() ![]() |
DeleteComposition(Database, String, Boolean) | |
![]() ![]() |
DeleteMaterial | |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() ![]() |
GetAssignedCompositionName | |
![]() ![]() |
GetAssignedCompositionObject | |
![]() |
GetAssignedObjects | |
![]() ![]() |
GetComposition | |
![]() |
![]() |
![]() |
GetPlyAt | |
![]() |
![]() ![]() |
HasComposition | |
![]() |
![]() |
![]() |
![]() |
![]() |
NumberOfPlies | |
![]() ![]() |
RemoveCompositionFrom | |
![]() |
SaveComposition | |
![]() ![]() |
SaveComposition(BIMComposition, Database, Boolean) | |
![]() |
![]() |
SetPlyAt | |
![]() |
SetToNull | (Overrides BIMObjectSetToNull) |
![]() |
![]() |
VariablePlyThickness |
Name | Description | |
---|---|---|
![]() ![]() |
Equality(BIMComposition, BIMComposition) | |
![]() ![]() |
Inequality(BIMComposition, BIMComposition) |
© Bricsys NV. All rights reserved. |