RevolvedSurfaceCreateRevolvedSurface
Method
|
Creates a revolved surface according to the
provided parameters.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public void CreateRevolvedSurface(
Entity revolveEntity,
Point3d axisPoint,
Vector3d axisDirection,
double revolveAngle,
double startAngle,
RevolveOptions revolveOptions
)
Public Sub CreateRevolvedSurface (
revolveEntity As Entity,
axisPoint As Point3d,
axisDirection As Vector3d,
revolveAngle As Double,
startAngle As Double,
revolveOptions As RevolveOptions
)
public:
void CreateRevolvedSurface(
Entity^ revolveEntity,
Point3d axisPoint,
Vector3d axisDirection,
double revolveAngle,
double startAngle,
RevolveOptions^ revolveOptions
)
member CreateRevolvedSurface :
revolveEntity : Entity *
axisPoint : Point3d *
axisDirection : Vector3d *
revolveAngle : float *
startAngle : float *
revolveOptions : RevolveOptions -> unit
Parameters
- revolveEntity Entity
- [in] Planar curve, region or planar surface to be
revolved.
- axisPoint Point3d
- [in] Point of the revolution axis.
- axisDirection Vector3d
- [in] Revolution axis' direction.
- revolveAngle Double
- [in] Angle of rotation (in radians).
- startAngle Double
- [in] Start angle of rotation (in radians).
- revolveOptions RevolveOptions
- [in] Options for revolving.
See Also