SplineToPolylineWithPrecision(Int32, Boolean, Boolean) Method

Generates a polyline to approximate a spline.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public Curve ToPolylineWithPrecision(
        int precision,
        bool bConvertAsArcs,
        bool bToLWPolyline
)

Parameters

precision  Int32
[in] Target precision value.
bConvertAsArcs  Boolean
[in] Flag that specifies whether to convert to arcs when the spline is planar.
bToLWPolyline  Boolean
[in] Flag that specifies whether to convert to Polyline when the spline is planar.

Return Value

Curve
Polyline from this spline.
Remarks
The precision value is suggested to be in the range [0..99] but can be higher. If the passed precision is negative, it is the maximum precision value that can be calculated internally.
See Also

©  Bricsys NV. All rights reserved.