Interval Class |
The Interval type exposes the following members.
Name | Description | |
---|---|---|
![]() |
Interval(Double) | Constructor for the Interval class. |
![]() |
Interval(Interval) | Copy constructor for the Interval class. |
![]() |
Interval(Double, Double, Double) | Constructor for the Interval class. |
![]() |
Interval(Int32, Double, Double) | Constructor for the Interval class. |
Name | Description | |
---|---|---|
![]() |
![]() |
Element | |
![]() |
IsBounded | |
![]() |
IsBoundedAbove | |
![]() |
IsBoundedBelow | |
![]() |
![]() |
IsSingleton | |
![]() |
IsUnbounded | |
![]() |
Length | |
![]() |
LowerBound | |
![]() |
Tolerance | |
![]() ![]() |
Unbounded | |
![]() |
![]() |
UpperBound |
Name | Description | |
---|---|---|
![]() |
Contains(Double) | Checks whether this interval contains the specified value. |
![]() |
Contains(Interval) | Checks whether this interval contains the specified interval. |
![]() |
![]() |
![]() |
![]() |
GetBounds | Retrieves an array that contains upper and lower bounds for this interval. |
![]() |
![]() |
![]() |
GetMerge | Retrieves the smallest interval containing both the specified interval and this interval. |
![]() |
![]() |
![]() |
IntersectWith | Retrieves the interval that is at the intersection of this interval and the specified interval. |
![]() |
IsContinuousAtUpper | Checks whether the specified interval is continuous with the upper bound of this interval. |
![]() |
IsDisjoint | Checks whether the specified interval is disjoint from this interval. |
![]() |
IsEqualAtLower(Double) | Checks whether the lower bounds of the specified interval and this interval are equal. |
![]() |
IsEqualAtLower(Interval) | Checks whether the lower bounds of the specified interval and this interval are equal. |
![]() |
IsEqualAtUpper(Double) | Checks whether the upper bounds of the specified interval and this interval are equal. |
![]() |
IsEqualAtUpper(Interval) | Checks whether the upper bounds of the specified interval and this interval are equal. |
![]() |
IsOverlapAtUpper | Checks whether the upper bounds of the specified interval and this interval are equal. |
![]() |
IsPeriodicallyOn | Checks whether the specified value is periodic on this interval. |
![]() |
Subtract | Subtracts the specified interval from this interval. |
![]() |
© Bricsys NV. All rights reserved. |