SurfaceBooleanUnion Method
|
Performs a Boolean union operation with this
surface and another specified surface.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public virtual Surface BooleanUnion(
Surface surface2
)
Public Overridable Function BooleanUnion (
surface2 As Surface
) As Surface
public:
virtual Surface^ BooleanUnion(
Surface^ surface2
)
abstract BooleanUnion :
surface2 : Surface -> Surface
override BooleanUnion :
surface2 : Surface -> Surface
Parameters
- surface2 Surface
- [in] Other surface to be united with this surface.
Return Value
Surface
Surface that represents the union operation result.
Remarks
This method is
implemented only for the ModelerGeometry and Spatial modelers. If
this surface is not derived from the Surface class or surfaces are
coplanar PlaneSurface objects, the result is stored in this
surface. Otherwise, this surface is not changed and the resulting
surface is returned by the method. If the resulting surface is
empty, i.e., both surfaces are empty, the method throws the
eNoIntersections exception, returns NULL, and this surface is not
changed. If the union operation fails, the method returns NULL, and
this surface is not changed.
See Also