AcSmAcDbObjectReferenceClass Class

Inheritance Hierarchy
SystemObject
  BricscadSmAcSmAcDbObjectReferenceClass

Namespace: BricscadSm
Assembly: BricscadSm (in BricscadSm.dll) Version: 25.0.0.0
Syntax
public class AcSmAcDbObjectReferenceClass : IAcSmAcDbObjectReference, 
        AcSmAcDbObjectReference, IOdSmInternal

The AcSmAcDbObjectReferenceClass type exposes the following members.

Constructors
  Name Description
Public method AcSmAcDbObjectReferenceClass Initializes a new instance of the AcSmAcDbObjectReferenceClass class
Top
Methods
  Name Description
Public method Clear  
Public method GetAcDbHandle  
Public method GetAcSmAcDbDatabase  
Public method GetClassID  
Public method GetDatabase  
Public method GetDirectlyOwnedObjects  
Public method GetDirectlyOwnedObjectsArray  
Public method GetFileName  
Public method GetImpl  
Public method GetIsDirty  
Public method GetObjectId  
Public method GetOwner  
Public method GetTypeName  
Public method InitNew  
Public method Load  
Public method ResolveAcDbObject  
Public method ResolveFileName  
Public method Save  
Public method SetAcDbHandle  
Public method SetAcDbObject  
Public method SetFileName  
Public method SetImpl  
Public method SetOwner  
Top
See Also

©  Bricsys NV. All rights reserved.