Entity2d Class

This class is the base class for all 2D geometric entities. For more information, see Overview of OdGe classes.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity2d
        More

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public abstract class Entity2d : DisposableWrapper, 
        ICloneable

The Entity2d type exposes the following members.

Properties
  Name Description
Top
Methods
  Name Description
Public method Clone Clones this entity and returns a handle to the cloned entity.
Public methodStatic member Create Creates an object based on the passed pointer and returns a handle to the created object.
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Public method IsEqualTo(Entity2d) Checks whether this entity is equal to the specified entity.
Public method IsEqualTo(Entity2d, Tolerance) Checks whether this entity is equal to the specified entity within a geometric tolerance.
Public method IsOn(Point2d) Checks whether the specified point is on this entity.
Public method IsOn(Point2d, Tolerance) Checks whether the specified point is on this entity according to a geometric tolerance.
Public method Mirror Mirrors this entity about the specified 2D line.
Public method RotateBy Rotates this entity about the specified point by the specified angle.
Public method ScaleBy Scales this entity by the specified scale factor about the specified point.
Public method TransformBy Applies the specified 2D transformation matrix to this entity.
Public method TranslateBy Translates this entity by applying a 2D translation vector.
Top
See Also
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity2d
        Teigha.GeometryBoundBlock2d
        Teigha.GeometryClipBoundary2d
        Teigha.GeometryCurve2d
        Teigha.GeometryCurveCurveIntersector2d
        Teigha.GeometryPointEntity2d

©  Bricsys NV. All rights reserved.