Graph Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.DatabaseServicesGraph
        Teigha.DatabaseServicesObjectIdGraph
        Teigha.DatabaseServicesXrefGraph

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public class Graph : DisposableWrapper

The Graph type exposes the following members.

Constructors
  Name Description
Public method Graph(GraphNode) Initializes a new instance of the Graph class
Protected method Graph(IntPtr, Boolean) Initializes a new instance of the Graph class
Top
Properties
  Name Description
Public property IsEmpty  
Public property NumNodes  
Public property RootNode  
Top
Methods
  Name Description
Public method AddEdge  
Public method AddNode  
Public method BreakCycleEdge  
Public method ClearAll  
Public methodStatic member Create  
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Public method DelNode  
Public method FindCycles  
Public method GetOutgoing  
Public method Node  
Public method Reset  
Public method SetNodeGrowthRate  
Top
See Also

©  Bricsys NV. All rights reserved.