Manager Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Bricscad.GraphicsSystemManager

Namespace: Bricscad.GraphicsSystem
Assembly: BrxMgd (in BrxMgd.dll) Version: 25.1.5.0
Syntax
public class Manager : DisposableWrapper

The Manager type exposes the following members.

Constructors
  Name Description
Protected method Manager Initializes a new instance of the Manager class
Top
Properties
  Name Description
Public property DeviceIndependentDisplaySize  
Public property DisplaySize  
Top
Methods
  Name Description
Public methodStatic member AcquireGraphicsKernel  
Public method CreateAutoCADDevice(IntPtr)  
Public method CreateAutoCADDevice(GraphicsKernel, IntPtr)  
Public method CreateAutoCADModel  
Public method CreateAutoCADModel(GraphicsKernel)  
Public method CreateAutoCADOffScreenDevice  
Public method CreateAutoCADView  
Public method CreateAutoCADViewport  
Public method CreateView  
Public method CreateViewport  
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Public method DestroyView  
Public method GetCurrentAcGsView  
Public method GetDBModel  
Public method GetGsModel  
Public method GetGsView  
Public method GetGUIDevice  
Public method GetOffScreenDevice  
Public method GetOffScreenView  
Public method ObtainAcGsView  
Public methodStatic member ReleaseGraphicsKernel  
Public method SetViewFromViewport  
Public method SetViewportFromView(Int32, View)  
Public method SetViewportFromView(Int32, View, Boolean, Boolean, Boolean)  
Top
Events
See Also

©  Bricsys NV. All rights reserved.