EntityExplodeGeometry Method
|
Explodes this entity into a set of simpler
entities.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public virtual void ExplodeGeometry(
DBObjectCollection entitySet
)
Public Overridable Sub ExplodeGeometry (
entitySet As DBObjectCollection
)
public:
virtual void ExplodeGeometry(
DBObjectCollection^ entitySet
)
abstract ExplodeGeometry :
entitySet : DBObjectCollection -> unit
override ExplodeGeometry :
entitySet : DBObjectCollection -> unit
Parameters
- entitySet DBObjectCollection
- [in/out] Receives a collection of new entities. May contain
elements before method execution; new elements are appended to the
end of the collection.
Remarks
Entities resulting
from the explosion are appended to the specified collection. The
newly created entities are not database-resident. The default
implementation of this function calls subWorldDraw() and makes
entities from geometry generated by subWorldDraw(). This method can
be overridden in custom classes.
See Also