LinearEntity2dIntersectWith(LinearEntity2d,
Tolerance) Method
|
Calculates an intersection point with the
specified line according to a geometry tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public Point2d[] IntersectWith(
LinearEntity2d line,
Tolerance tolerance
)
Public Function IntersectWith (
line As LinearEntity2d,
tolerance As Tolerance
) As Point2d()
public:
array<Point2d>^ IntersectWith(
LinearEntity2d^ line,
Tolerance tolerance
)
member IntersectWith :
line : LinearEntity2d *
tolerance : Tolerance -> Point2d[]
Parameters
- line LinearEntity2d
- [in] Line to intersect with.
- tolerance Tolerance
- [in] Geometric tolerance.
Return Value
Point2d
An array that contains a single intersection point.
See Also