Curve3dGetSamplePoints(Double, Double, Double) Method

Retrieves specified arrays of sample points along this curve and their parameter values.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public PointOnCurve3d[] GetSamplePoints(
        double fromParameter,
        double toParameter,
        double chordHeight
)

Parameters

fromParameter  Double
[in] First parameter value that represents the start of the interval.
toParameter  Double
[in] Second parameter value that represents the end of the interval.
chordHeight  Double
[in] Approximation spacing (step) along a parametric range.

Return Value

PointOnCurve3d
Array of sample points.
See Also

©  Bricsys NV. All rights reserved.