BoundBlock3d(Point3d, Vector3d, Vector3d, Vector3d) Constructor

Constructor for the BoundBlock3d class. Constructs a bounding block with the specified base point.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public BoundBlock3d(
        Point3d point1,
        Vector3d dir1,
        Vector3d dir2,
        Vector3d dir3
)

Parameters

point1  Point3d
[in] Base of a parallelogram bounding block.
dir1  Vector3d
[in] First side of a parallelogram bounding block.
dir2  Vector3d
[in] Second side of a parallelogram bounding block.
dir3  Vector3d
[in] Third side of a parallelogram bounding block.
See Also

©  Bricsys NV. All rights reserved.