ColorFromColorIndex Method

Returns new color object by color method and index.

Namespace: Teigha.Colors
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public static Color FromColorIndex(
        ColorMethod colorMethod,
        short colorIndex
)

Parameters

colorMethod  ColorMethod
ColorMethod object.
colorIndex  Int16
Color index (ACI).

Return Value

Color
New color object.
Remarks
colorIndex must be one of the following:
Value Description
0 ByBlock
7 Foreground color
256 ByLayer
1 Red
2 Yellow
3 Green
4 Cyan
5 Blue
6 Magenta
8-255 Defined by display device
257 No color
See Also

©  Bricsys NV. All rights reserved.