Curve2dGetSamplePoints(Int32)
Method
|
Retrieves an array of sample points along this
curve.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public Point2d[] GetSamplePoints(
int numSample
)
Public Function GetSamplePoints (
numSample As Integer
) As Point2d()
public:
array<Point2d>^ GetSamplePoints(
int numSample
)
member GetSamplePoints :
numSample : int -> Point2d[]
Parameters
- numSample Int32
- [in] Quantity of sample points.
Return Value
Point2d
Array of sample points.
Remarks
For example, if
parametric range of this curve is [0,2] and the numSample is 5, the retrieved points correspond to
the following parametric values: 0, 0.5, 1, 1.5, 2.
See Also