ResultBuffer Class

This class implements the resulting buffer object that represents the structure for storing and passing the tagged data of all basic data types between various objects using different technologies.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.DatabaseServicesResultBuffer

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public sealed class ResultBuffer : DisposableWrapper, 
        IEnumerable, IFormattable

The ResultBuffer type exposes the following members.

Constructors
  Name Description
Public method ResultBuffer Default constructor for the ResultBuffer class.
Public method ResultBuffer(TypedValue) Constructor for the ResultBuffer class. Creates a buffer with the specified array of typed values.
Top
Properties
  Name Description
Top
Methods
  Name Description
Public method Add(Object) Adds the specified typed object as the next object in the sequence of tagged data.
Public method Add(TypedValue) Adds the specified typed value as the next object in the sequence of tagged data.
Public method AsArray Returns this resulting buffer as an array of typed values.
Public methodStatic member Create Creates an object based on the passed pointer and returns a handle to the created object.
Public method Equals Checks objects for equality.
(Overrides DisposableWrapperEquals(Object))
Public method GetEnumerator Returns the enumerator for the resulting buffer.
Public method GetHashCode Retrieves the object hash code.
(Overrides DisposableWrapperGetHashCode)
Public method ToString Returns an equivalent string representation of this object.
(Overrides ObjectToString)
Public method ToString(IFormatProvider) Returns an equivalent string representation of this object.
Public method ToString(String, IFormatProvider) Returns an equivalent string representation of this object.
Top
Operators
  Name Description
Public operatorStatic member Equality(ResultBuffer, ResultBuffer) Equality operator for the ResultBuffer class.
Public operatorStatic member Inequality(ResultBuffer, ResultBuffer) Inequality operator for the ResultBuffer class.
Top
See Also

©  Bricsys NV. All rights reserved.