BIMRoom Class |
The BIMRoom type exposes the following members.
Name | Description | |
---|---|---|
![]() |
BIMRoom | Initializes a new instance of the BIMRoom class |
![]() |
BIMRoom(BIMRoom) | Initializes a new instance of the BIMRoom class |
![]() |
BIMRoom(ObjectId) | Initializes a new instance of the BIMRoom class |
Name | Description | |
---|---|---|
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
Name | (Overrides BIMObjectName) |
![]() |
ObjId | |
![]() |
RoomArea | |
![]() |
RoomDepartment | |
![]() |
RoomIdent | |
![]() |
RoomName | |
![]() |
RoomNumber | |
![]() |
RoomRepresentation | |
![]() |
Name | Description | |
---|---|---|
![]() |
AssignToBuilding(BIMBuilding) | |
![]() ![]() |
AssignToBuilding(ObjectId, BIMBuilding) | |
![]() |
AssignToStory(BIMStory) | |
![]() ![]() |
AssignToStory(ObjectId, BIMStory) | |
![]() ![]() |
BuildNonAssociativeRoom | |
![]() |
CreateAssociativeRoom | |
![]() |
CreateNonAssociativeRoom | |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() ![]() |
GetAllRooms(Database) | |
![]() ![]() |
GetAllRooms(BIMBuilding, Database) | |
![]() ![]() |
GetAllRooms(BIMStory, Database) | |
![]() |
GetAssignedBuilding | |
![]() |
GetAssignedLocation | |
![]() |
GetAssignedStory | |
![]() |
GetBoundingElements | |
![]() |
![]() |
![]() |
GetOpenings | |
![]() ![]() |
GetRoomArea | |
![]() ![]() |
GetRoomDepartment | |
![]() ![]() |
GetRoomDescription | |
![]() ![]() |
GetRoomIdent | |
![]() ![]() |
GetRoomName | |
![]() ![]() |
GetRoomNumber | |
![]() ![]() |
GetRoomRepresentation | |
![]() |
![]() |
![]() |
IsAssociativeRoom | |
![]() ![]() |
IsAssociativeRoom(ObjectId) | |
![]() |
![]() |
![]() |
![]() |
![]() ![]() |
SetRoomDepartment | |
![]() ![]() |
SetRoomDescription | |
![]() ![]() |
SetRoomName | |
![]() ![]() |
SetRoomNumber | |
![]() ![]() |
SetRoomRepresentation | |
![]() |
SetToNull | (Overrides BIMObjectSetToNull) |
![]() |
![]() |
UnassignLocation | |
![]() ![]() |
UnassignLocation(ObjectId) | |
![]() |
UpdateAssociativeRoom |
Name | Description | |
---|---|---|
![]() ![]() |
Equality(BIMRoom, BIMRoom) | |
![]() ![]() |
Inequality(BIMRoom, BIMRoom) |
© Bricsys NV. All rights reserved. |