NurbSurfaceSetControlPointAt
Method
|
Sets a new control point (in WCS coordinates)
at a specified position in the control points vector.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public void SetControlPointAt(
int iUDegree,
int iVDegree,
Point3d point
)
Public Sub SetControlPointAt (
iUDegree As Integer,
iVDegree As Integer,
point As Point3d
)
public:
void SetControlPointAt(
int iUDegree,
int iVDegree,
Point3d point
)
member SetControlPointAt :
iUDegree : int *
iVDegree : int *
point : Point3d -> unit
Parameters
- iUDegree Int32
- [in] An index of a control point in the u-direction. Index
starts from the 0 value.
- iVDegree Int32
- [in] An index of a control point in the v-direction. Index
starts from the 0 value.
- point Point3d
- [in] A new control point (in WCS coordinates) to be set at the
specified position.
Remarks
If the surface
doesn't contain control point information, the method throws the
eFail exception. If the iUDegree or iVDegree
parameters are out of range, throws the eOutOfRange exception. If this method is not
implemented for a specific modeler, throws the eNotImplementedYet exception.
See Also