LayerStateManagerGetLayerStateMask
Method
|
Retrieves a layer state mask from a specific
layer state. A layer state mask determines which layer attributes
are stored in the layer state.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public LayerStateMasks GetLayerStateMask(
string name
)
Public Function GetLayerStateMask (
name As String
) As LayerStateMasks
public:
LayerStateMasks GetLayerStateMask(
String^ name
)
member GetLayerStateMask :
name : string -> LayerStateMasks
Parameters
- name String
- [in] Name of the layer state to export.
Return Value
LayerStateMasks
A layer state mask is a combination of one or more of the
following:
NameValueNone 0x0000 On 0x0001 Frozen 0x0002 Locked
0x0004 Plot 0x0008 NewViewport 0x0010 Color 0x0020 LineType 0x0040
LineWeight 0x0080 PlotStyle 0x0100 CurrentViewport 0x0200
Transparency 0x0400
See Also