Curve3dGetClosestPointTo(Point3d,
Tolerance) Method
|
Retrieves the closest point on this curve to
the specified point within a specified tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public PointOnCurve3d GetClosestPointTo(
Point3d point,
Tolerance tolerance
)
Public Function GetClosestPointTo (
point As Point3d,
tolerance As Tolerance
) As PointOnCurve3d
public:
PointOnCurve3d^ GetClosestPointTo(
Point3d point,
Tolerance tolerance
)
member GetClosestPointTo :
point : Point3d *
tolerance : Tolerance -> PointOnCurve3d
Parameters
- point Point3d
- [in] Point to which the closest point is calculated.
- tolerance Tolerance
- [in] Geometric tolerance.
Return Value
PointOnCurve3d
The closest point on this curve.
See Also