Transient
|
The TransientManager type exposes the following members.
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper) |
![]() ![]() |
CurrentTransientManager | |
![]() |
IsDisposed | (Inherited from DisposableWrapper) |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper) |
Name | Description | |
---|---|---|
![]() |
AddChildTransient | Appends a child drawable to a parent drawable in the transient drawables manager. |
![]() |
AddTransient | Appends a child drawable to a parent drawable in the transient drawables manager. |
![]() |
CreateObjRef | Creates an object that contains all the relevant information
required to generate a proxy used to communicate with a remote
object. (Inherited from MarshalByRefObject) |
![]() |
DeleteUnmanagedObject | (Overrides DisposableWrapperDeleteUnmanagedObject) |
![]() |
Dispose | (Inherited from DisposableWrapper) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper) |
![]() |
Equals | (Inherited from DisposableWrapper) |
![]() |
EraseChildTransient | Erases a child drawable from a parent drawable in the transient drawables manager. |
![]() |
EraseTransient | Erases a drawable from the transient drawables manager. |
![]() |
EraseTransients | Erases all drawables from the specified drawable mode and order. |
![]() |
Finalize | (Inherited from DisposableWrapper) |
![]() |
GetFreeSubDrawingMode | Finds a free order for the specified drawable mode. |
![]() |
GetHashCode | (Inherited from DisposableWrapper) |
![]() |
GetLifetimeService | Retrieves the current lifetime service object that controls the
lifetime policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
GetType | Gets the Type of the current
instance. (Inherited from Object) |
![]() |
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime
policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object) |
![]() |
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject) |
![]() |
ToString | Returns a string that represents the current object. (Inherited from Object) |
![]() |
UpdateChildTransient | Updates a child drawable of a parent drawable in the transient drawables manager (partial updates for a parent drawable). |
![]() |
UpdateTransient | Updates a drawable in the transient drawables manager. |
© Bricsys NV. All rights reserved. |