ArcDimension(Point3d, Point3d, Point3d, Point3d, String, ObjectId) Constructor

Constructor. Creates an ArcDimension object with specified parameters.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public ArcDimension(
        Point3d centerPoint,
        Point3d xLine1Point,
        Point3d xLine2Point,
        Point3d arcPoint,
        string dimensionText,
        ObjectId dimensionStyle
)

Parameters

centerPoint  Point3d
Center point of the arc.
xLine1Point  Point3d
First extension line point.
xLine2Point  Point3d
Second extension line point.
arcPoint  Point3d
Point lying on the dimension arc.
dimensionText  String
Dimension text to replace the measured value text.
dimensionStyle  ObjectId
ObjectId of the dimension style that is used to draw the dimension entity.
See Also

©  Bricsys NV. All rights reserved.