NurbSurfaceRebuild(Int32, Int32, Int32, Int32) Method

Rebuilds the NURBS surface with a specified new degree and quantity of control points in the u- and v-directions. This operation modifies the shape of the surface.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public void Rebuild(
        int iUDegree,
        int iVDegree,
        int iNumUCtrlPts,
        int iNumVCtrlPts
)

Parameters

iUDegree  Int32
[in] New degree value in the u-direction.
iVDegree  Int32
[in] New degree value in the v-direction.
iNumUCtrlPts  Int32
[in] New quantity of control points in the u-direction.
iNumVCtrlPts  Int32
[in] New quantity of control points in the v-direction.
Remarks
Currently not implemented.
See Also

©  Bricsys NV. All rights reserved.