Constraints
|
The ConstraintsGroup3d type exposes the following members.
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper) |
![]() |
BlockId | returns the owner block table record for this constraints group object |
![]() |
ConstraintByNodeId | returns the constraint object as specified by its index (nodeId) |
![]() |
Constraints | returns all Constraint3d objects for this constraints group as array |
![]() |
HasSketchPlane | returns whether this constraints group uses a sketch plane remark reserved for future use, returns false |
![]() |
IsDisposed | (Inherited from DisposableWrapper) |
![]() |
SketchPlane | returns the sketch plane for this constraints group Reserved for future use, not implemented yet |
![]() |
Transient | returns whether this constraints group is transient or not remark reserved for future use, returns false |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper) |
Name | Description | |
---|---|---|
![]() |
AddConstraint(ConstraintType, ConstraintArgument) | adds a new constraint of specified type with given subentities to this constraints group |
![]() |
AddConstraint(ConstraintType, FullSubentityPath) | adds a new constraint of specified type with given subentities to this constraints group |
![]() |
CreateObjRef | Creates an object that contains all the relevant information
required to generate a proxy used to communicate with a remote
object. (Inherited from MarshalByRefObject) |
![]() |
DeleteConstraint | deletes the specified constraints object from this constraints group |
![]() |
DeleteUnmanagedObject | (Overrides DisposableWrapperDeleteUnmanagedObject) |
![]() |
Dispose | (Inherited from DisposableWrapper) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper) |
![]() |
Equals | (Inherited from DisposableWrapper) |
![]() |
Evaluate | evaluate all constraints of this constraints group |
![]() |
Finalize | (Inherited from DisposableWrapper) |
![]() |
GetHashCode | (Inherited from DisposableWrapper) |
![]() |
GetLifetimeService | Retrieves the current lifetime service object that controls the
lifetime policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
GetType | Gets the Type of the current
instance. (Inherited from Object) |
![]() |
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime
policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object) |
![]() |
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject) |
![]() |
ToString | Returns a string that represents the current object. (Inherited from Object) |
© Bricsys NV. All rights reserved. |