HyperLink Class

This class is the base class for HyperLink objects. HyperLink objects contain the following data: NameDescriptionHyperlink Name Filename or URL. Sublocation Named view, range of cells, etc. Description Display name for a hyperlink.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.DatabaseServicesHyperLink

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public sealed class HyperLink : DisposableWrapper

The HyperLink type exposes the following members.

Constructors
  Name Description
Public method HyperLink Default constructor for the HyperLink object.
Top
Properties
  Name Description
Public property Description Property that represents the description associated with this HyperLink object.
Public property DisplayString  
Public property IsOutermostContainer Property that indicates whether this HyperLink object is associated with the outermost container.
Public property Name Property that represents the name associated with this HyperLink object.
Public property NestedLevel Property that represents the nesting level of this HyperLink object.
Public property SubLocation Property that represents the sublocation associated with this HyperLink object.
Top
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides DisposableWrapperEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides DisposableWrapperGetHashCode)
Top
See Also

©  Bricsys NV. All rights reserved.