AssocVariableSetExpression
Method
|
Sets the expression as a string and
syntactically checks it.
Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in
TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public void SetExpression(
string newExpression,
string evaluatorId,
bool checkForCyclicalDependencies,
bool updateDependenciesOnReferencedSymbols,
ref string errorMessage,
bool silentMode
)
Public Sub SetExpression (
newExpression As String,
evaluatorId As String,
checkForCyclicalDependencies As Boolean,
updateDependenciesOnReferencedSymbols As Boolean,
ByRef errorMessage As String,
silentMode As Boolean
)
public:
void SetExpression(
String^ newExpression,
String^ evaluatorId,
bool checkForCyclicalDependencies,
bool updateDependenciesOnReferencedSymbols,
String^% errorMessage,
bool silentMode
)
member SetExpression :
newExpression : string *
evaluatorId : string *
checkForCyclicalDependencies : bool *
updateDependenciesOnReferencedSymbols : bool *
errorMessage : string byref *
silentMode : bool -> unit
Parameters
- newExpression String
- [in] Expression or an empty string.
- evaluatorId String
- [in] Identifier of the expression evaluator as string. If
empty, the default evaluator will be used.
- checkForCyclicalDependencies Boolean
- [in] Flag that specifies whether to checks that this variable
is not referenced by the new expression.
- updateDependenciesOnReferencedSymbols Boolean
- [in] Flag that specifies whether to erase all existing
associative value dependencies on the symbols referenced by the
previous expression and introduce new dependencies on the symbols
referenced by the new expression.
- errorMessage String
- [out] Receives error message, if errors occur.
- silentMode Boolean
- [in] Flag that specifies whether to disable printing an error
message if the expression string is invalid.
Remarks
The checkForCyclicalDependencies parameter can help to
detect cyclical dependency between the variables.
See Also