TransientDrawingMode Enumeration
|
Represents a drawing mode of a transient.
Drawing modes can be used to specify the draw order. For a 2D
graphics system, the topmost level is Contrast while the
bottom-most level is Main. For a 3D graphics system,
DirectShortTerm, Highlight and Contrast members also indicate the
draw order, and the DirectShortTerm mode is the bottom-most
level.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public enum TransientDrawingMode
Public Enumeration TransientDrawingMode
public enum class TransientDrawingMode
type TransientDrawingMode
Members
Member name |
Value |
Description |
Main |
0 |
Main drawing mode (for internal use). For a 3D graphics system,
this mode uses the main z-buffer. |
Sprite |
1 |
Sprite drawing mode (for internal use). For a 3D graphics
system, this mode uses a separate z-buffer for sprites. |
DirectShortTerm |
2 |
ShortTerm drawing mode. For a 3D graphics system, renders
directly to the device. |
Highlight |
3 |
Highlight drawing mode. For 2D and 3D graphics systems, renders
transient directly to the device highlight effects. |
DirectTopmost |
4 |
Renders transient above all other render modes except the
contrast mode. |
Contrast |
5 |
For 2D and 3D graphics systems, renders transient directly to
the device in contrast style. |
Count |
6 |
Count of drawing modes (for internal use). |
See Also