RibbonPanel Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Bricscad.WindowsRibbonPanel

Namespace: Bricscad.Windows
Assembly: BrxMgd (in BrxMgd.dll) Version: 25.1.5.0
Syntax
public class RibbonPanel : DisposableWrapper, 
        ICloneable, INotifyPropertyChanged

The RibbonPanel type exposes the following members.

Constructors
  Name Description
Public method RibbonPanel Initializes a new instance of the RibbonPanel class
Top
Properties
  Name Description
Public property IsEnabled  
Public property IsVisible  
Public property Source  
Public property Tab  
Top
Methods
  Name Description
Public method Clone  
Public method CopyFrom  
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Protected method Dispose(Boolean) Releases the unmanaged resources used by the RibbonPanel and optionally releases the managed resources
(Overrides DisposableWrapperDispose(Boolean))
Public method FindItem(String)  
Public method FindItem(String, Boolean)  
Public method GetWPFControl  
Protected method ICloneable_Clone  
Protected method OnPropertyChanged  
Public method SetWPFControl  
Top
Events
  Name Description
Public event PropertyChanged  
Top
Fields
See Also

©  Bricsys NV. All rights reserved.