AcSmAcDbLayoutReferenceClass Class

Inheritance Hierarchy
SystemObject
  BricscadSmAcSmAcDbLayoutReferenceClass

Namespace: BricscadSm
Assembly: BricscadSm (in BricscadSm.dll) Version: 25.0.0.0
Syntax
public class AcSmAcDbLayoutReferenceClass : IAcSmAcDbLayoutReference, 
        AcSmAcDbLayoutReference, IOdSmInternal

The AcSmAcDbLayoutReferenceClass type exposes the following members.

Constructors
  Name Description
Public method AcSmAcDbLayoutReferenceClass Initializes a new instance of the AcSmAcDbLayoutReferenceClass class
Top
Methods
  Name Description
Public method Clear  
Public method GetAcDbHandle  
Public method GetAcSmAcDbDatabase  
Public method GetClassID  
Public method GetDatabase  
Public method GetDirectlyOwnedObjects  
Public method GetDirectlyOwnedObjectsArray  
Public method GetFileName  
Public method GetImpl  
Public method GetIsDirty  
Public method GetName  
Public method GetObjectId  
Public method GetOwner  
Public method GetOwnerAcDbHandle  
Public method GetTypeName  
Public method InitNew  
Public method Load  
Public method ResolveAcDbObject  
Public method ResolveFileName  
Public method Save  
Public method SetAcDbHandle  
Public method SetAcDbObject  
Public method SetFileName  
Public method SetImpl  
Public method SetName  
Public method SetOwner  
Public method SetOwnerAcDbHandle  
Top
See Also

©  Bricsys NV. All rights reserved.