DrawableOverrule Class

This class overrules a subset of drawable linked operations which a drawable object specifies. It is used as a base class for classes derived from Drawable to change their behavior. Each default implementation calls the corresponding method of the target class.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.RuntimeOverrule
          Teigha.GraphicsInterfaceDrawableOverrule

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public abstract class DrawableOverrule : Overrule

The DrawableOverrule type exposes the following members.

Constructors
  Name Description
Protected method DrawableOverrule Initializes a new instance of the DrawableOverrule class
Top
Properties
  Name Description
Top
Methods
  Name Description
Public method RegenSupportFlags Overrules the Drawable.RegenSupportFlags method.
Public method SetAttributes Overrules the Drawable.SetAttributes method. The default implementation of this method calls the Drawable.setAttributes method.
Public method SetCustomFilter Enables usage of the IsApplicable method to check whether an overrule is applied.
(Overrides OverruleSetCustomFilter)
Public method SetExtensionDictionaryEntryFilter Enables usage of an extension dictionary lookup for checking whether an overrule is applied.
(Overrides OverruleSetExtensionDictionaryEntryFilter(String))
Public method SetIdFilter Enables usage of ID lookups for checking whether an overrule is applied.
(Overrides OverruleSetIdFilter(ObjectId))
Public method SetNoFilter Disables the filter methods (SetCustomFilter, SetExtensionDictionaryEntryFilter, SetIdFilter, SetXDataFilter) and the IsApplicable() method for checking whether an overrule is applied.
(Overrides OverruleSetNoFilter)
Public method SetXDataFilter Enables the usage of xdata for checking whether an overrule is applied.
(Overrides OverruleSetXDataFilter(String))
Public method ViewportDraw Overrules the Drawable.ViewportDraw method. The default implementation of this method calls the Drawable.ViewportDraw method.
Public method ViewportDrawLogicalFlags Overrules the Drawable.ViewportDrawLogicalFlags method. The default implementation of this method calls the Drawable.ViewportDrawLogicalFlags method.
Public method WorldDraw Overrules the Drawable.WorldDraw method. The default implementation of this method calls the Drawable.WorldDraw method.
Top
See Also

©  Bricsys NV. All rights reserved.