PropertyDataType Enumeration


Namespace: Bricscad.Opm
Assembly: BrxMgd (in BrxMgd.dll) Version: 25.1.5.0
Syntax
public enum PropertyDataType
Members
Member name Value Description
None 0  
Integer 1  
Bool 2  
CheckBox 3  
Double 4  
Angle 5  
Distance 6  
Area 7  
Factor 8  
String 9  
Color 10  
Lineweight 11  
Point2d 12  
Point3d 13  
Vector2d 14  
Vector3d 15  
Point2dUcs 16  
Point3dUcs 17  
Vector2dUcs 18  
Vector3dUcs 19  
Range 20  
GradientName 21  
PatternType 22  
PatternName 23  
AnnotativeScale 24  
Volume 25  
Expression 26  
Quantity 27  
Mass 28  
ObjectHandle 30  
Layer 31  
Linetype 32  
Block 34  
View 35  
Ucs 36  
Textstyle 37  
Dimstyle 38  
Tablestyle 39  
Mlinestyle 40  
Mleaderstyle 41  
Material 42  
Layout 43  
PlotStyleName 44  
Arrowhead 45  
File 50  
Folder 51  
Callback 52  
Enum 60  
Combo 61  
DataTypeMask 4,095  
FlagReloadPanelOnModify 4,096  
FlagNoUserEdit 8,192  
FlagGlobalRange 16,384  
See Also

©  Bricsys NV. All rights reserved.