Solid3dSlice(Plane,
Boolean) Method
|
Slices the solid with a plane and transforms
the native solid to be the portion remaining on the positive side
of the normal of the slicing plane.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public virtual Solid3d Slice(
Plane plane,
bool negativeHalfToo
)
Public Overridable Function Slice (
plane As Plane,
negativeHalfToo As Boolean
) As Solid3d
public:
virtual Solid3d^ Slice(
Plane^ plane,
bool negativeHalfToo
)
abstract Slice :
plane : Plane *
negativeHalfToo : bool -> Solid3d
override Slice :
plane : Plane *
negativeHalfToo : bool -> Solid3d
Parameters
- plane Plane
- [in] Slicing plane.
- negativeHalfToo Boolean
- [in] Flag determining whether the other (negative) part of the
native solid should be created as a separate solid.
Return Value
Solid3d
Created solid representing the negative half of the native
solid.
Remarks
This method is
implemented only for the Spatial modeler.
See Also