TransformOverruleGetTransformedCopy Method
|
Creates a copy of the specified entity and
applies the passed transformation to the newly created copy.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public virtual Entity GetTransformedCopy(
Entity entity,
Matrix3d transform
)
Public Overridable Function GetTransformedCopy (
entity As Entity,
transform As Matrix3d
) As Entity
public:
virtual Entity^ GetTransformedCopy(
Entity^ entity,
Matrix3d transform
)
abstract GetTransformedCopy :
entity : Entity *
transform : Matrix3d -> Entity
override GetTransformedCopy :
entity : Entity *
transform : Matrix3d -> Entity
Parameters
- entity Entity
- [in] Entity to copy.
- transform Matrix3d
- [in] 3D transformation matrix to apply to the copied
entity.
Return Value
Entity
See Also