BIMClassification Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Bricscad.BimBIMClassification

Namespace: Bricscad.Bim
Assembly: BrxMgd (in BrxMgd.dll) Version: 25.1.5.0
Syntax
public class BIMClassification : DisposableWrapper

The BIMClassification type exposes the following members.

Constructors
  Name Description
Public method BIMClassification Initializes a new instance of the BIMClassification class
Top
Properties
  Name Description
Top
Methods
  Name Description
Public methodStatic member ClassifyAs(ObjectId, BimTypeElement)  
Public methodStatic member ClassifyAs(ObjectId, String, Boolean)  
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Public methodStatic member GetAllClassificationNames  
Public methodStatic member GetAllClassified  
Public methodStatic member GetAllClassifiedAs(BimTypeElement, Database)  
Public methodStatic member GetAllClassifiedAs(String, Boolean, Database)  
Public methodStatic member GetAllUnclassified  
Public methodStatic member GetAllUsedClassificationNames  
Public methodStatic member GetAllUsedClassifications  
Public methodStatic member GetClassification  
Public methodStatic member GetClassificationName  
Public methodStatic member GetDescription  
Public methodStatic member GetName  
Public methodStatic member GetPropertiesMap  
Public methodStatic member GetPropertiesString  
Public methodStatic member GetProperty  
Public methodStatic member HasProperty  
Public methodStatic member IsClassifiedAs(ObjectId, BimTypeElement)  
Public methodStatic member IsClassifiedAs(ObjectId, String, Boolean)  
Public methodStatic member IsClassifiedAsAnyBuildingElement  
Public methodStatic member IsUnclassified  
Public methodStatic member SetDescription  
Public methodStatic member SetName  
Public methodStatic member SetProperty  
Public methodStatic member UnClassify  
Top
See Also

©  Bricsys NV. All rights reserved.