XrefFullSubentityPath Class

This class uniquely defines external reference subentities within a database. Each instance of this class consists of a SubentId object, an ordered array of object identifiers, and an ordered array of entity handles. The SubentId consists of the index and subentType of the object. The array of object IDs and the array of handles define the path to the subentity from the outermost entity (in paper space or model space) to the entity containing the subentity.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.DatabaseServicesXrefFullSubentityPath

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public class XrefFullSubentityPath : DisposableWrapper

The XrefFullSubentityPath type exposes the following members.

Constructors
  Name Description
Protected method XrefFullSubentityPath Initializes a new instance of the XrefFullSubentityPath class
Top
Properties
  Name Description
Public property SubentId Property that represents a copy of the embedded SubentId object in the full subentity path.
Top
Methods
  Name Description
Public method AppendObjectId Appends an object identifier to an array of object identifiers that are related to this XrefFullSubentityPath.
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Public method DwgIn Reads the .dwg file format data of this object from the specified file.
Public method DwgOut Writes the .dwg file format data of this object to the specified filer.
Public method DxfOut(DxfFiler) Reads the DXF file format data of this object from the specified file.
Public method DxfOut(DxfFiler, Int32) Writes the DXF file format data of this object to the specified filer.
Public method GetObjectIds Returns an array of object identifiers that are related to this XrefFullSubentityPath.
Public method XrefObjHandles Returns an ordered array of database entity handles.
Top
See Also

©  Bricsys NV. All rights reserved.