MPolygonAppendMPolygonLoop Method
|
Appends a polygon loop.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public virtual void AppendMPolygonLoop(
BulgeVertexCollection bulgeVertexCol,
bool excludeCrossing,
double tolerance
)
Public Overridable Sub AppendMPolygonLoop (
bulgeVertexCol As BulgeVertexCollection,
excludeCrossing As Boolean,
tolerance As Double
)
public:
virtual void AppendMPolygonLoop(
BulgeVertexCollection^ bulgeVertexCol,
bool excludeCrossing,
double tolerance
)
abstract AppendMPolygonLoop :
bulgeVertexCol : BulgeVertexCollection *
excludeCrossing : bool *
tolerance : float -> unit
override AppendMPolygonLoop :
bulgeVertexCol : BulgeVertexCollection *
excludeCrossing : bool *
tolerance : float -> unit
Parameters
- bulgeVertexCol BulgeVertexCollection
- [in] Collection of bulge values for corresponding 2D
vertices.
- excludeCrossing Boolean
- [in] Flag that specifies whether to disable creating a polygon
if there are crosses between loops.
- tolerance Double
- [in] Measurement accuracy tolerance.
See Also