CommonDrawDeviation Method

Retrieves the recommended maximum deviation of the current vectorization for the specified point on a curve.

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public abstract double Deviation(
        DeviationType deviationType,
        Point3d pointOnCurve
)

Parameters

deviationType  DeviationType
[in] Deviation type.
pointOnCurve  Point3d
[in] Point on a curve.

Return Value

Double
recommended maximum difference (with respect to the current active viewport) between the actual curve or surface, and the tessellated curve or surface.
Remarks
deviationType must be one of the following: * MaxDevForCircle (0) * MaxDevForCurve (1) * MaxDevForBoundary (2) * MaxDevForIsoline (3) * MaxDevForFacet (4)
See Also

©  Bricsys NV. All rights reserved.